Tuesday, February 1, 2011

Using JPA 2.0 in WebLogic 10.3.4

Starting with the Oracle WebLogic 10.3.4 release it is now possible to upgrade to using JPA 2.0. The release includes TopLink (with EclipseLink 2.1.2).

Since WebLogic 10.3.4 is a compliant Java EE 5 implementation it is required to ship out of the box with support for EJB 3.0 and thus JPA 1.0. If you wish to upgrade your install to allow JPA 2.0 use you must follow install a small patch, which is documented here.

If you are making use of Oracle Enterprise Pack for Eclipse the new includes support for using the JPA 2.0 capabilities.



ArvedS said...

Interesting information. I was just talking to a ops support guy for one client yesterday about server upgrade paths, and if they were to migrate today, from oc4j, it would most likely be to this version of WebLogic. The fact that with relatively little effort they could then enable JPA 2.0, and start slowly taking advantage of it, is something that I'll pass along. This particular fellow I mention already did some experimentation with key applications and WebLogic.

sajjad paracha said...

I recently fixed this problem on weblogic 10.3.3 which is JPA1.0 complient I believe it will also work in your case have a look at below blog post